[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[pbsd-mg2] Re: cache problem again

   I'm sorry.  I have little time today.  This message is in English.
   Thank you for your understanding.

In message <199908140848.RAA19564@mail.ca2.so-net.ne.jp> "Takemura" writes:
: Wanner, it seems that kernel have some cache problem. I wonder if your 
: trouble is same one. Would you try option HPCMIPS_PGSIZE_16K ?

I found some time last night to try again on my Freestyle.  I used the
newest sources (the just before sato-san's changes) and the latest
pbsdboot with the following options:

options                HPCMIPS_L1CAHCE_DISABLE # disable L1 cache for debug
options                HPCMIPS_FLUSHCACHE_XXX
options                HPCMIPS_PGSIZE_16K      # page size is 16KB

and ipfilter removed from GENERIC.  I still get hangs when it tries to
exec init.  When I type a character (I'm using serial console) I break
to the debugger.  When I tried to load debugging information to get a
better traceback, I can't break into the debugger at all! 

This versoin does fix a bug I had noticed in the Aug 10 version I
tried before.  In the older version, a button press would generate a
fault and land me in the debugger.  In the August 20th version that I
tried, it prints the mask of the button pressed.